Support Call Center Phone System Issue

Minor incident Support Team Operations
2022-06-23 07:42 CDT · 4 hours, 44 minutes

Updates

Resolved

The phone provider issue has been resolved.

June 23, 2022 · 12:27 CDT
Monitoring

The phone system provider issues have been resolved and we will continue to monitor.

June 23, 2022 · 09:41 CDT
Issue

We are currently experiencing an issue with our Support Call Center’s phone system. We are working to resolve as soon as possible.

If you have any Support inquiries, please email us at support@limoanywhere.com and we will be happy to assist you.

June 23, 2022 · 07:42 CDT

← Back