Reported Slowness and Errors Issue

Minor incident Administration System DriverAnywhere Reporting & Analytics
2022-05-10 13:29 CDT · 38 minutes

Updates

Resolved

This issue is resolved.

May 10, 2022 · 14:07 CDT
Issue

We are getting reports of slowness and errors appearing in Limo Anywhere. We are currently working to resolve this issue as soon as possible. We apologize for the inconvenience.

May 10, 2022 · 13:37 CDT

← Back