System Slowness

Minor incident Administration System DriverAnywhere Reporting & Analytics
2022-03-28 18:40 CDT · 21 minutes

Updates

Resolved

This issue is resolved.

March 28, 2022 · 19:02 CDT
Issue

We have had reports of system slowness or delays with logging in from users. We are currently working on getting the issue resolved. We apologize for any inconvenience this may have caused.

March 28, 2022 · 18:41 CDT

← Back