Reporting & Analytics Module.

Minor incident Administration System
54 minutes, 43 seconds

Updates

Resolved

The issue with the Reporting & Analytics module has been resolved.

January 20, 2020 · 11:13 CDT
Investigating

We are currently experiencing an issue with the Reporting & Analytics module. This has been reported for investigation and fix. We apologize for any inconvenience this may cause.

January 20, 2020 · 10:20 CDT

← Back