Slowness Reported

Minor incident Administration System
2021-12-06 16:04 CST · 55 minutes

Updates

Resolved

This issue has been resolved.

December 6, 2021 · 16:59 CST
Monitoring

We have received several reports of temporary slowness over the last 15 minutes. We are actively investigating and will post an update if we find anything systemic.

December 6, 2021 · 16:08 CST

← Back