Reports of Slowness in LA

Minor incident Administration System DriverAnywhere Reporting & Analytics
2021-11-01 11:38 CST · 9 minutes

Updates

Resolved

This issues has been resolved. We appreciate your time and patience.

November 4, 2021 · 10:26 CST
Issue

We are getting reports of slowness in LA. We are currently investigating and working to resolve this issue as soon as possible. We apologize for the inconvenience.

November 4, 2021 · 10:26 CST

← Back