We have been receiving reports from some users experiencing slowness with pages loading.

Minor incident Administration System
2019-11-19 12:04 CST · 49 minutes, 41 seconds

Updates

Resolved

This issue has been resolved.

November 19, 2019 · 12:53 CST
Investigating

We have been receiving reports from some users experiencing slowness with pages loading. We are currently investigating this for fix ASAP. We apologize for any inconvenience this may cause.

November 19, 2019 · 12:06 CST

← Back