We have received reports from some user experiencing slowness or pages not loading.

Minor incident Administration System
2019-11-11 15:57 CST · 34 minutes, 14 seconds

Updates

Resolved

This issue has been resolved.

November 11, 2019 · 16:31 CST
Issue

We have received reports from some user experiencing slowness or pages not loading. We are currently investigating the issue for fix. We apologize for any inconvenience this may cause.

November 11, 2019 · 15:58 CST

← Back