Queued emails

Minor incident Administration System
2021-09-08 14:51 CST · 2 hours, 52 minutes, 58 seconds

Updates

Resolved

The issue with emails being queued has been resolved. We will continue to monitor the situation. we apologize for any inconvenience this may have caused.

September 8, 2021 · 17:44 CST
Monitoring

Emails that have been previously queued are now sending. We are continuing to monitor the situation.

September 8, 2021 · 15:41 CST
Investigating

We have had reports from some users of emails being queued. We are currently investigating the issue. We apologize for any inconvenience this may cause.

September 8, 2021 · 14:53 CST

← Back