LA System Running Slow and Errors

Major incident Administration System
2019-10-29 11:18 CDT · 1 hour, 8 minutes

Updates

Resolved

This issue has been resolved. We apologize for the inconvenience and appreciate your patience in this matter.

November 4, 2021 · 10:24 CDT
Investigating

We have reports of Limo Anywhere users experiencing slowdown in system and getting Problem Encountered errors. We are currently investigating and will get this issue resolved ASAP.

November 4, 2021 · 10:24 CDT

← Back