Slowness Reported

Minor incident Administration System
2021-06-01 10:19 CST · 54 minutes, 59 seconds

Updates

Resolved

We were able to identify the root cause of the slowness and resolve the issue. We’ve monitored the system activity for the last 30 minutes and can confirm the results are as expected. If you are still experiencing any slowness, please reach out to our Support department.

June 1, 2021 · 11:14 CST
Issue

Some operators are experiencing slowness while using/logging in to Limo Anywhere. We are currently investigating the issue and will provide an update shortly.

June 1, 2021 · 10:21 CST

← Back