Emails Not Sending Issue

Minor incident Administration System
2021-05-06 10:35 CST · 17 minutes, 6 seconds

Updates

Resolved

The issue with emails not sending from Limo Anywhere has been resolved. We apologize for the inconvenience and thank you for your patience.

May 6, 2021 · 10:52 CST
Issue

We are getting reports of emails currently being queued and not sending from Limo Anywhere. We are currently working to resolve this issue as soon as possible. We apologize for the inconvenience.

May 6, 2021 · 10:45 CST

← Back