Errors in Limo Anywhere

Major incident Administration System DriverAnywhere Reporting & Analytics
2021-03-11 10:59 CDT · 31 minutes, 26 seconds

Updates

Resolved

This issue has been resolved. We apologize for the inconvenience and thank you for your time and patience in this matter.

March 11, 2021 · 11:31 CDT
Issue

We are receiving reports of errors in Limo Anywhere. We are currently working to resolve this issue as soon as possible. We apologize for the inconvenience.

March 11, 2021 · 11:02 CDT

← Back