Slowness in LA

Minor incident Administration System
2020-11-25 09:18 CDT · 3 hours, 52 minutes, 40 seconds

Updates

Resolved

Slowness issues have been resolved. Thank you for your patience and we apologize for the inconvenience.

November 25, 2020 · 13:10 CDT
Investigating

We are getting reports of slowness in Limo Anywhere. We are currently investigating and will resolve as soon as possible. We apologize for the inconvenience.

November 25, 2020 · 09:27 CDT

← Back