Problem Encountered & Queued Emails

Minor incident Administration System
2020-10-29 16:51 CST · 33 minutes, 54 seconds

Updates

Resolved

This issue has been resolved.

October 29, 2020 · 17:25 CST
Issue

Limo Anywhere is currently investigating reports from some users experiencing a problem encountered message and emails being queued but either delayed or not sent. We apologize for any inconvenience this may cause and working to resolve the issue as soon as possible.

October 29, 2020 · 16:53 CST

← Back