Reporting & Analytics Issue

Minor incident Reporting & Analytics
2020-10-20 14:15 CDT · 5 hours, 6 minutes, 53 seconds

Updates

Resolved

The issue with Reporting & Analytics has been resolved.

October 20, 2020 · 19:21 CDT
Investigating

We are currently working to resolve issue with Reporting & Analytics section of Limo Anywhere as soon as possible. We apologize for the inconvenience.

October 20, 2020 · 17:03 CDT
Resolved

This issue with Reporting & Analytics has been resolved. Thank you for your time and patience.

October 20, 2020 · 15:36 CDT
Issue

The Reporting & Analytics section of Limo Anywhere is currently experiencing an issue. We are working to get this resolved as soon as possible. We apologize for the inconvenience.

October 20, 2020 · 14:26 CDT

← Back