Momentary Service Disruption

Major incident Reporting & Analytics DriverAnywhere Administration System
2020-08-24 16:40 CST · 32 minutes, 24 seconds

Updates

Resolved

This issue has been resolved

August 24, 2020 · 17:13 CST
Issue

Limo Anywhere experienced a momentary service disruption. The issue has been resolved and is being evaluated and monitored.

August 24, 2020 · 16:51 CST

← Back