Problem Encountered Issues

Major incident Administration System
48 minutes, 18 seconds

Updates

Resolved

This issue has been resolved. Thank you for your patience and we apologize for the inconvenience.

August 19, 2020 · 04:08 CDT
Investigating

We have reports of users getting Problem Encountered message in Limo Anywhere. This may be due to current maintenance going on. We are investigating and monitoring and will get resolved soon. We apologize for the inconvenience.

August 19, 2020 · 03:23 CDT

← Back