CC Processing Errors

Minor incident Administration System
2023-08-15 10:17 CDT · 41 minutes

Updates

Resolved

The error previously reported has been addressed. If you are still experiencing an issue when attempting to process a credit card payment, please contact our Support department at 972-701-8887 x 2.

August 15, 2023 · 10:57 CDT
Issue

Users may be receiving an error message when attempting to process a credit card transaction. We are aware of the issue and expect a resolution shortly. We appreciate your patience,

August 15, 2023 · 10:17 CDT

← Back