Issue

Major incident Administration System
2023-05-30 13:24 CDT · 3 hours, 28 minutes

Updates

Resolved

The previously reported performance issues, including slow page loading and occasional errors, have been resolved. Our system is now operating normally.

May 30, 2023 · 16:52 CDT
Investigating

We are continuing to work on the issue reported earlier. We had to briefly reboot some systems which interrupted connections for a few moments. We are seeing some improvements post-update but performance is not yet back to normal levels. We will provide further updates as the effort continues. We appreciate your patience and understanding.

May 30, 2023 · 16:09 CDT
Issue

We’re currently aware of reported issues related to system performance, including slow page loading and occasional errors. Our team is actively investigating this and is working on a resolution. We apologize for any inconvenience and appreciate your patience. Please stay tuned for updates.

May 30, 2023 · 13:24 CDT

← Back