Issues logging in

Minor incident Administration System DriverAnywhere Reporting & Analytics
2023-03-09 19:33 CDT · 1 hour, 45 minutes

Updates

Resolved

The issue with some users reporting not being able to log in has been resolved.

Customers may experience issues with emails being delayed and/or queued, but will be sent as the queue is cleared. We are continuing to investigate and will provide update when fully resolved.

March 9, 2023 · 21:19 CDT
Investigating

We are currently receiving reports that a subset of users are receiving an error when attempting to log in. We are working on resolving the problem, and apologize for any inconvenience.

March 9, 2023 · 19:34 CDT

← Back