Phone System Issues

Minor incident Support Team Operations
2022-11-17 08:49 CST · 28 minutes

Updates

Resolved

The issue with our phone system has been resolved. We apologize for any inconvenience this may have caused.

November 17, 2022 · 09:17 CST
Issue

We are currently experiencing issues with our phone system. If you need support with Limo Anywhere, then please send us an email at support@limoanywhere.com or send us a chat.

We are currently working to resolve this issue as soon as possible. We apologize for the inconvenience.

November 17, 2022 · 08:51 CST

← Back